Secure SIM Activation - Outage
Incident Report for Secure Group
Resolved
The incident has been resolved.
Posted 16 days ago. Apr 06, 2019 - 23:10 EEST
Investigating
We're experiencing a major outage with Secure SIM activations and our carrier is currently looking into the issue.

Thank you for your patience!
Secure Group Support
Posted 16 days ago. Apr 06, 2019 - 19:52 EEST
This incident affected: Secure Phone SIM Card Service and Secure BlackBerry SIM Card Service.