Secure Manager and SAS - Outage
Incident Report for Secure Group
Resolved
This incident has been resolved.
Posted 21 days ago. Aug 30, 2019 - 17:03 EEST
Update
We are continuing to work on a fix for this issue.
Posted 21 days ago. Aug 30, 2019 - 16:24 EEST
Identified
We're still experiencing a major outage with Secure Manager and are currently working on resolving the issue.

Thank you for your patience!
Secure Group Support
Posted 21 days ago. Aug 30, 2019 - 16:17 EEST
This incident affected: Secure Manager and Secure Administration System (SAS).