SIM Card Service Partial Outage in Europe
Incident Report for Secure Group
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 05, 2019 - 17:22 EET
Identified
Due to an issue with GPRS roaming exchange (GRX) hubs, some roaming users in Europe may experience data connection interruptions. The issue has been identified and the network engineers are working on it.

Thank you for your patience!
Secure Group Support
Posted 7 months ago. Feb 05, 2019 - 15:00 EET
This incident affected: Secure Phone SIM Card Service.