Blackberry activations issue
Incident Report for Secure Group
Resolved
This incident has been resolved.
Posted 9 days ago. Aug 12, 2019 - 15:29 EEST
Investigating
We're experiencing an issue with Blackberry activations and are currently looking into the issue.

Thank you for your patience!
Secure Group Support
Posted 9 days ago. Aug 12, 2019 - 12:54 EEST
This incident affected: Secure BlackBerry.