Network Infrastructure - Outage
Incident Report for Secure Group
Resolved
This incident has been resolved.
Posted May 21, 2020 - 11:07 EEST
Investigating
We're experiencing a major outage with our Network Infrastructure and are currently looking into the issue.

Thank you for your patience!
Secure Group Support
Posted May 21, 2020 - 10:41 EEST
This incident affected: Secure Manager, Secure Administration System (SAS), Secure Email, Secure Chat, Secure Voice, and Network Infrastructure.