Secure Phone visibility group creation issue
Incident Report for Secure Group
Resolved
This incident has been resolved.
Posted Aug 12, 2019 - 12:04 EEST
Investigating
We're experiencing an issue with Secure Phone visibility group creation and are currently looking into it.

Thank you for your patience!
Secure Group Support
Posted Aug 12, 2019 - 11:18 EEST
This incident affected: Secure Manager.