Email services - intermittent issues
Incident Report for Secure Group
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 09, 2019 - 00:03 EET
Identified
We're currently investigating the reports and monitoring the email flow.

Activation of new BB accounts may be affected.

Thank you for your patience!
Secure Group Support
Posted 2 months ago. Mar 08, 2019 - 21:55 EET