Secure mangare - Outage
Incident Report for Secure Group
Resolved
This incident has been resolved.

Thank you for your patience!
Posted 21 days ago. Aug 30, 2019 - 15:53 EEST
Identified
We're experiencing a major outage with Secure Manager and are currently looking into the issue.

Thank you for your patience!
Secure Group Support
Posted 21 days ago. Aug 30, 2019 - 15:34 EEST
This incident affected: Secure Manager.